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Deploying and Testing App on Real TV 
 
This document describes how to deploy, test, debug the application on Real (actual) TV. 
 
Exporting Project 

This document describes how to export the project from LG IDE for remote debugging on TV. 
 
Uploading App on App Test Menu 

This document describes how to upload the application on App Test Menu and download the DRM-packaged file on 
USB. 
 
Deploying App on TV 

This document describes how to deploy the DRM-packaged application stored in USB onto TV. 
 
Debugging App on TV with LG IDE 

This document describes how to debug the application on TV with LG IDE. 
 
Running App on TV with LG IDE 

This document describes how to run the application on TV with LG IDE. 
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Exporting Project 

Caution 

Please read the following note first. 
 
1) If Remote Debugging is not needed, remove the 'LG Inspector' folder in the zip file which is exported from "Export 
App Test" menu. Or, just compress the WebContent folder of your project into zip format. Then, upload the zip file on 
LG Developer Site > App Test menu. 
 
2) If Remote Debugging is needed, you must export the app with "Export App Test" menu and upload the exported 
zip file on LG Developer Site > App Test menu. 
 
If an application zip file includes the 'LG Inspector' folder and deployed on TV when developer is not using remote 
debugging function, the following problems may occur. 
- Back and Smart Home button does not work normally. 
- Screen freezes after app is launched for the first time and then back button and Home button are pressed 
sequentially.  
In this case, you should power off the TV and restart the application. 

 
LG IDE provides automatic exporting function for developers to debug the application on a TV remotely. 
 
1. In IDE, select the project and click [File > Export App Test]. 
Or, click [Export App Test] from the right-click menu in your project. 

 
2. In the following window, select application type, target TV and project from the list in the left.  
 

 
 
In 'Downloadable' type, select the project on the left. Then, the 'WebContent' folder contents of the project are 
displayed on the right. Set the destination folder where exported file is stored to 'Archive File'. The file is exported as 
the name of the selected project by default. 
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In 'Web (URL based Web app)' type, set the destination folder where exported file is stored to 'Archive File'. The file 
is exported as the name of 'LGInspector.zip' by default.  
 
Click [Finish]. 

 
3. Then, the exported project file (.zip) will be created under the destination folder with 'LG Inspector' folder included.  
 
4. To launch the application on a TV for remote debugging, you must upload the exported file on the [App Test] menu 
in LG Developer (http://webostv.developer.lge.com) and download the DRM-packaged file into the USB. 
 

Note 

In Downloadable type, you can test an application on a TV and debug the application on LG IDE. 
In Web type, you can test an application on Web and debug the application on LG IDE. In this case, set the URL on 
the [App Test] menu in LG Developer. 

 
Refer to the next sections. 

http://webostv.developer.lge.com/
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Uploading App on App Test Menu 

To test your application on a TV, you have to register your own application on [App Test] page first. Once upload is 

done, the application is DRM packaged. You can download it to USB and test it on a TV.  
 
The LG Smart TV models that have only one USB Port, released before year 2012, cannot be used for testing 
application. You must check if your device is released since 2012 or has two USB Ports before starting the test. 
 
 
Steps for App Testing 

 

 
 
Step 1. Upload the application in .zip format on [App Test] page. 
Refer to Uploading Web application , Uploading Flash application, Uploading AIR application, and Uploading 
Marmalade/Unity application. 

 
Step 2. Download the DRM-packaged file into USB from the [App Test] page.  
Refer to Downloading Application on USB. 

 
Step 3. Insert the USB into LG Smart TV and test the application on a TV.  
Refer to Inserting USB into LG Smart TV. 

 
 
App Test Menu 
Go to [DISCOVER > Legacy Platform (NetCast) > USB App Test] menu n LG Developer 
(http://webostv.developer.lge.com). You must login if you are not logged into the website. 

 

Note 

If you are using Internet Explorer 6, you must change the internet options first. In IE6, go to [Tools > Internet 
Options > Security tab > Custom Level] and change the options as below.  

 

 
This section includes the following sections. 
 Checking the SDK Version of TV 
 Uploading Web App 
 Uploading Flash App 

http://webostv.developer.lge.com/
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 Uploading AIR App 
 Uploading Marmalade/Unity App 

 

Checking the SDK Version of TV 

Before starting application testing on a TV, you need to check the SDK version of TV first. Only 01.05 or higher 

version is available for application testing. Also, it is recommended that firmware version of the TV has the latest 
version. 
 

Note 

Currently, application testing function through App Test menu is supported on LG Smart TV and Smart TV Upgrader 
(SP820). LG Media products do not support App Test using USB. 

 
From the [Home] menu of your LG Smart TV, select [SETUP > SUPPORT > Product/Service] and check 'SDK 

Version'. 
 

 
 
If the SDK version is lower than 01.05, try software update as below.  
 

 
 

Note 

In some countries, software update may not has been applied.  
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Uploading Web App 

In App Test page, web applications can be uploaded with following steps.  
 
1. Uploaded applications list is shown. You can check detailed information for each application by clicking it. Click 
[New App Test] to upload a new application. 

 

 
 
2. Fill out the blank referring to the following table. 
 

 
 

Attribute Description 

App Title 
Enter alphanumeric characters for the application title. 
The title should be lesser than 100 characters long. 

App Type 

Select “Web”. 
For Sub Type;  
If you are not a partner with LG, select “All” for Sub Type. 
 
If you are a partner with LG, follow this guideline for Sub Type. If you cannot sure 
the app types, contact your LGE person in charge and select the guided Sub Type. 
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Attribute Description 

All : All web apps except following specific apps. 
M14+(webOS) : M14+ chipset-targeted web apps. 
H15(webOS) : H15 chipset-targeted web apps. 
LM15U(webOS) : LM15U chipset-targeted web apps. 
LM14A(webOS) : LM14A chipset-targeted web apps. 

File Upload - URL 

For hosted (URL-based) web application, enter the URL of web application server. 
Example) "http://www.abc.com/index.html", "http://www.abc.com/" 
 
All resources of hosted web application are stored on web server managed by 
seller. The web application is executed by accessing web server using the URL of 
the web server. The web server can be implemented with any language. 
 
For packaged (downloadable) web application, enter the exact relative path of a 
html file which will be initially executed. The path should be relative to the root path 
of the compressed file. 
Example) "index.html", "./test/index.html", "test/index.html" 

Note 

Do not use "http://" or URL for packaged web application type. 

File Upload – File Upload 

For packaged web application, select an application file to upload. (The file 
extension must be zip) 

The packaged web applications are recommended to be 20MB or so but the 
application is capable of uploading up to 100MB. 

Note 

For hosted web application, do not enter anything. 

App Icon 
Enter the app icon in a jpg, gif or png format.  
The icon must be under 100KB and greater than 200 x 200 pixels. 

 
4. Click [Save]. If you click [Cancel], the page goes back to the App Test main page. 

 
5. Uploaded application information page is displayed. 
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 File Basic Information: The uploaded file name and app icon image are displayed. 
 Item: The registered in-app items are displayed. 
 CP Option Information: The registered CP options are displayed.  
 Download DRM applied file: Check the [Terms and Conditions] before downloading the application. 
 [Modify], [Delete] : Click this button to modify the information or delete app file. 
 [List]: Click this button to goes back to the application list page. 

 
6. Download the DRM-packed file on USB by clicking [Download]. 
For downloading on USB, refer to Downloading App on USB. 

 

Note 

The above page will show CP option information with default values even though you did not check on it. 
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Uploading Flash App 

In App Test page, Flash applications can be uploaded with following steps. 
 
1. Click [New App Test] to upload a new application. 

 
2. Follow the next steps. 
 

 
 

Attribute Description 

App Title 
Enter alphanumeric characters for the application title. 
The title can be lesser than 100 characters long. 

App Type Select "Adobe Flash" and sub type in application type list. 

File Upload  Select an application file to upload. (The file extension must be zip) 

File Upload – Main Run 
File 

Select a main file to run. When you click on [Search], a list of .swf files of the 
application are shown in the popup. 
 

 
 

App Icon 
Enter the app icon in a jpg, gif or png format.  
The icon must be under 100KB and greater than 200 x 200 pixels. 

Spec Check List 
For Flash or AIR application, you should enter the optimized resolution of the 
application so that it can run on TV normally. 
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Attribute Description 

 

 
 
3. Click [Save]. If you click [Cancel], the page goes back to the App Test main page. 

 

Note 

For the "Item" option, refer to the Uploading Web App. 

 
4. Uploaded application information page is shown as follows. 
 

 
 
 File Basic Information: The uploaded file name and app icon image are displayed. 
 Item: The registered in-app items are displayed. 
 Download DRM applied file: Check the [Terms and Conditions] before downloading the application. 
 [Modify], [Delete] : Click this button to modify the information or delete app file. 
 [List]: Click this button to goes back to the application list page. 

 
5. Download the DRM-packed file on USB by clicking [Download]. 
For downloading on USB, refer to Downloading App on USB. 
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Uploading AIR App 

In App Test page, AIR applications can be uploaded with following steps. 
 
1. Uploaded applications list is shown. You can check detailed information for each application by clicking it. Click 
[New App Test] to upload a new application. 

 
2. Follow the next steps. 
 

 
 

Attribute Description 

App Title 
Enter alphanumeric characters for the application title. 
The title can be lesser than 100 characters long. 

App Type Select "Adobe AIR" and sub type in application type list. 

File Upload  Select an application file to upload. (The file extension must be zip) 

File Upload – Main Run 
File 

Select a main file to run. When you click on [Search], a list of .xml files of the 

application are shown in the popup. Select "META-INF/AIR/application.xml" from 
this list, then, the popup disappears. 
 

 
 

App Icon 
Enter the app icon in a jpg, gif or png format.  
The icon must be under 100 KB and greater than 200 x 200 pixels. 

Spec Check List 
For AIR application, you should enter the optimized resolution of the application so 
that it can run on TV normally. 
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Attribute Description 

 
 

 

Note 

When AIR application is uploaded for App Test in LG Developer or Seller Lounge, the applications should be 
packaged as below. 
 
1. If you are using LG Smart TV SDK V2.1.1, run [Step-2 Build and Run Over Emulator] from the Command menu 

of Adobe Flash CS. And files and folders are created as below. Among them, copy .air file (mandatory) and 
lgconfig.xml (option) into a folder to be packaged. 

 
2. Copy other content files and folders necessary to run application into a folder to be packaged. 

  
3. Select a packaged folder in Digital Signing Tool and proceed packaging.(App Test is possible with .zip file in LG 
Developer.) 

 
 
For more information, refer to "LG Flash, AIR Application Development Guide" in the [DISCOVER > Legacy 
Platform (NetCast) > Technical Notes] at LG Developer site. 

 
3. Click [Save]. If you click [Cancel], the page goes back to the App Test main page. 

 
4. The view of uploaded application information is similar to those of Flash Application on App Test.  
 
5. Download the DRM-packed file on USB by clicking [Download]. 
For downloading on USB, refer to Downloading App on USB. 

 
 

Uploading Marmalade/Unity App 

In App Test page, Marmalade and Unity applications can be uploaded as the same as the Flash Application. 
 
For uploading Marmalade/Unity applications for app test, refer to Uploading Flash App. 

 

http://webostv.developer.lge.com/discover/netcast/technical-notes/
http://webostv.developer.lge.com/discover/netcast/technical-notes/
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Deploying App on Real TV 

Once you have uploaded your application on [App Test] page at LG Developer website, you can download the DRM-

packaged application into USB to deploy it on LG Smart TV.  
 
The LG Smart TV models that have only one USB Port, released before year 2012, cannot be used for deploying the 
application. You must check if your device is released since 2012 or has two or more USB Ports before start to 
deploy. 
 

Follow to the next steps: 

 

1. Downloading App on USB 

2. Inserting USB into LG Smart TV 

 

 

Downloading App on USB 

1. Create lgapps\installed folder in USB. 

 
2. Go to [App Test] menu and select the application to deploy on a TV. Download the DRM-packaged file (.zip) on 

your PC. Then, unzip it. 
 
3. You will see a folder named with a number, for example "8". This number is an application ID. Copy this folder 
under "lgapps\installed" folder in USB. 

 

 
 
 

Inserting USB into LG Smart TV 

1. Sign in to LG Smart TV with ID and password of LG Apps TV. Then, insert the USB into TV. 
 

 
 

Note 

If the Country Setting on TV is not set to your own country, the login icon for LG Smart TV cannot be displayed. 
Thus, you cannot test your application on TV without changing the Country Setting. 
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2. Click [MyApps] on the bottom of TV screen. 
 

 
 

3. In MyApps page, press arrow (▶) on the screen or [CH Down] button from IR Remote to see your application. 

 

 
 
4. You can see and test your application running on a TV. 
 

 
 

Note 

When testing application on a TV, the DRM-packaged application must receive the key from SDP for decryption. But 
the key may be delayed or not received depending on the network status. In this case, you can try to input USB again. 
 
Also, applications on USB have the different decryption keys. If one application was displayed on TV but the other 
applications were not displayed on TV, it means the one application received the key only for decryption.  
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5. In LG Smart TV released in 2012 and 2013, you should click on the following USB icon in MyApps page after 
inserting the USB into the TV. 
 

 
 

Note 

- Once an application is installed through USB, it is executable on maximum 5 devices with same LG Apps IDs.  
- If an application has been executed with ID "A", the application is not shown on other TVs with ID "B". 
- However, once an application is installed on TV, it can be shown with different IDs on the same TV. 
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Debugging App on TV with LG IDE 

1. In LG IDE, click [Run Emulator > Debug Configuration] menu or toolbar icon . Then, the Debug 

Configuration window will be opened. 
 
2. Select the Target and target TV. Then, click [Apply]. 

 

Note 

The IP address of the local server, your current PC, is displayed in the 'Real TV' field. 

 

 
 
3. Click [Debug]. Then, LG IDE starts to begin the [Remote Debug] mode. Or, click [Close] to begin by [Run 
Emulator > Debug] menu later. 

 
4. Be sure that your project should have been exported from LG IDE for testing the application on a TV. Refer to 
Exporting Project to export and launch the application on a TV for testing purpose. 

 

Caution 

As your current PC works as local server when debugging the application on TV, the PC and TV should be 
connected to the same network. 

 
5. The IDE waits for TV to be connected to the local server PC and the application to be launched on the TV browser. 
 

 
 
6. If the application is launched on a TV and the TV successfully accessed to the local server PC, [Remote Debug] 
mode is opened in IDE and developer can debug the application on a TV using ‘Web Inspector’. 
 
Refer to the following URL to learn about ‘Web Inspector’: https://developers.google.com/chrome-developer-
tools/docs/overview 

 

Note 

The Safari browser should be installed on your PC to use Web Inspector in LG IDE. 

https://developers.google.com/chrome-developer-tools/docs/overview
https://developers.google.com/chrome-developer-tools/docs/overview
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Running App on TV with LG IDE 

1. In LG IDE, click [Run Emulator > Run Configuration] menu or toolbar icon . Then, the Run Configuration 

window will be opened. 
 
2. Select Target, Start Page, and HTTP Web Server Port Number. Then, click [Apply]. 

 

Note 

- If you change the server port number, LG IDE will be restarted. As '8787' is preoccupied, do not use it. 
- The IP address of the local server, your current PC, is displayed in the 'Real TV' field. 

 

 
 
3. If you click [Run], the project starts to run on the target. You can also run the project by [Run Emulator > Run] 

menu later. 
 
4. Be sure that the application is launched on a TV using the USB first. For detailed information on how to launch the 
application on a TV, refer to Deploying App on Real TV. 

 

Caution 

As your current PC works as local server when debugging the application on TV, the PC and TV should be 
connected to the same network. 

 
If the application is not launched on the TV browser yet, the following popup appears. 
 

 
 
5. When the application is launched on a TV and the TV successfully accessed to the local server PC, you can check 
the application on real browser. 
 
 


